You are here:

Audio Systems/distorted s's and t's


kevin wrote at 2013-07-30 08:00:04
Holy bad equipment batman!!  I have the identical set up.. although its 2013 ( 4 years later than the original post ) and my rotel gear is all relatively new.. 1070 amp..1082 pre...1055 cd.. paradigm 60.. and polks RTi  and I have the exact same problem at all listening levels. Its driving me crazy. Its not the speakers as I have switched them with the polks and some JBL's.  Does anyone have any suggestions ? Sounds silly, but maybe the ALL rotel set up is not compatible ??

Audio Systems

All Answers

Answers by Expert:

Ask Experts




Audio Design Engineer; systems, loudspeakers, cd/dvd players, etc. I am knowledgeable in all high end audio equipment and installations. MAKE SURE YOU GIVE A MAKE AND MODEL NUMBER AND CAR IF IT IS AN AUTO QUESTION. Note: I am getting some who ask good questions that take a lot of time to research but then the questioner fails to read the answer. Please don't ask questions unless you are seriously looking for an answer. If you find an answer to your question otherwise then let me know with your reply. Thank you.


Have been associated with audio design, standards, testing and component systems for over 40 years.

Life Fellow Member of Audio Engineering Society Life Senior Member of Institute of Electronic and Electrical Engineers

Review technical manuscripts for IEEE Spectrum Write occasionally for high-end audio publications


Past/Present Clients
Past Employee/advisor to several well known audio products manufacturers

©2016 All rights reserved.