You are here:

Dodge Repair/2001 Dakota hard starting


QUESTION: Hi Roland,
Hoping you can assist me a bit here.  I have '01 Dakota with the 3.9 L engine, 161,000 miles.  It is experiencing a hard starting issue where It will take several seconds to start.  either warm or cold. Thinking the fuel pressure regulator was to blame, I tested the pressure at the rail and it measured a constant 49 PSI.  Any thoughts as to  where I can look beyond the regulator? as that no longer seems to be the issue.  


ANSWER: Hi Paul,
Unfortunately I don't have a manual for that year model of Dakota. But if the engine has an egr valve (exhaust gas recirculation) then you would do well to check out the valve to be sure that the stem isn't gummed up and failing to allow the valve to close all the way which leads to hard starting and poor idle, and dieing when slowing to a stop. If the stem of the valve is accessible (betweem the vacuum on the top and the body of the valve proper) then spray some WD-40 on the stem where it enters the valve's body. Then move the stem back and forth by means of a screwdriver inserted in the slot of the valve stem.
The other thing to try would be to get a fault code readout. A nationwide autoparts store, such as Autozone, will often do that for free, or an independent shop will do it for around $40. Let me know the 4-digit fault code numbers that are found and we'll go from there.
Please 'rate' my answer (see below).

---------- FOLLOW-UP ----------

QUESTION: Hi Roland, There is no EGR for this engine.  I do have a OBD2 Scan tool and pulled the codes,  Those have been fixed and I have not seen the check engine light on recently.  Cannot recall the exact codes, one was related to the GAS cap, the other related to some brittle hoses at the charcoal canister.    

Any thoughts of where else to look? it does have new plugs and plug wires as well.


Hi Paul,
If there are no codes (but why not look again?), and no egr then I can only suggest that you take look at the MAP sensor. It is about the only other component that I have experienced can go bad but not so far as to set a fault code. When that happens you can have an incorrect mixture for starting. It happened to me on my '89 2.5L 4 cyl engine. The sensor was saying it thought the vehicle was a 10,000 ft altitude but it really was at sea level, but no code was detected because it was a tenable but seriously incorrect signal voltage.
Please 'rate' my answer, and if you choose give me another nomination for 'volunteer of the month'.

Dodge Repair

All Answers

Answers by Expert:

Ask Experts


Roland Finston


Free fast answer to your repair question about a Chrysler/Dodge/Plymouth car, minivan, SUV, or truck. Problems with electronically controlled engines and transmissions as well as body wiring problems are my specialty. This free troubleshoot advice forum helps you diagnose faults, minimize repair costs or do-it-yourself.

I answer questions seven days a week and respond to you in about 30 minutes. "Maxed Out" means I am answering another question or asleep overnight so try again later.

I have do-it-yourself experience (50+ years) and a library of 100 1982-2011 Chrysler factory shop manuals and 20 multi-manual Chrysler Corp. CD's.

I was voted "Top expert" from 2010-2015 here at AllExperts, and have answered 20,000+ questions.


Five decades as a 'do-it-yourselfer' on domestic and imported cars

Yahoo Autos Group called The Chrysler Lebaron Club (co-moderator)

Degrees in Physics/bruised knuckles.

Awards and Honors
"Top expert" of 2010, 2011, 2012, 2013, 2014, and 2015 here at Allexperts. Quickest "average response time" at Allexperts (currently no. 1).

©2016 All rights reserved.