You are here:

Ford Repair/no start when hot


2006 explorer-78K miles. always starts when cold. drive an hour and stop for a few mins. zip. all instrument lights on but nothing-no start. If it's a hot day and been driven for 30 mins or so-the air bag light comes on and the speedometer stops working and sticks at the speed when the AB light comes on. If the engine is then cut off-again nothing-no start. Let the engine sit for 10 mins or so-starts right up and odometer gauge goes back to zero and no AB light. please help-dealer says they can't duplicate the problem and just want to start replacing very expensive electrical parts!

There are a couple service messages about this or smiliar concerns. first is tsb 10-2-15. because this is coming directly from a ford site. i am unable to attach it but- you ca google it and it will come up- just type ford tsb 10-2-15. the other which is more common and most likely the cause is tsb 06-10-7. again google this.. it describes your concern pretty well. good luck and please get back to me.. -b-

Ford Repair

All Answers

Ask Experts




I can help you to answer most vehicle questions dating from 2000 and on. cars and light trucks relating to ford electrical. air conditioning, heating, brakes, steering and almost all driveabilty concrns. I am well versed in the area of Fords new sync/ford and lincoln my touch systems.


I have worked for Ford for the last 15 years and recently received my master technician status.

Ford master tecnician. Ford certified in steering, suspension, brakes, climate control, electrical and driveability concerns. light transission concerns. as well as certifed in Fords new sync/Ford/Lincoln mt Touch systems

Awards and Honors
Ford master technician

©2016 All rights reserved.