General Networking/Lan/Wan/Cannot get IP from DHCP

Advertisement


Question
Sir,

I have a simple setup of a switch(3524) and a stand alone AP(1210).

The AP is configured as DHCP server.

The problem is my wireless devices cannot get IP from it and the following messages will prompt up. It cannot receive an IP from DHCP server.
=================
*Mar  1 00:38:24.979: %DOT11-6-ASSOC: Interface Dot11Radio1, Station   5426.960f.9225 Associated KEY_MGMT[NONE]
*Mar  1 00:39:26.060: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 5426.960f.9225 Reason: Sending station has left the BSS
=================

However, my PC connected to the switch CAN get IP from the DHCP server without any issue.

Config of switch and AP are listed below. Any idea?

Thank you.

============
C3524#
C3524#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5.3)WC(1), MAINTENANCE INTERIM SOFTWARE
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Mon 30-Apr-01 07:51 by devgoyal
Image text-base: 0x00003000, data-base: 0x003331F4

ROM: Bootstrap program is C3500XL boot loader

C3524 uptime is 1 minute
System returned to ROM by power-on
System image file is "flash:c3500XL-c3h2s-mz.120-5.3.WC.1.bin"


cisco WS-C3524-PWR-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K bytes of memory.
Processor board ID FAA0550L012, with hardware revision 0x00
Last reset from power-on

Processor is running Enterprise Edition Software
Cluster command switch capable
Cluster member switch capable
24 FastEthernet/IEEE 802.3 interface(s)
--More--         2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:08:21:77:0A:C0
Motherboard assembly number: 73-4033-07
Power supply part number: 34-0968-01
Motherboard serial number: FAA051608GU
Power supply serial number: LIT04331259
Model revision number: A0
Motherboard revision number: B0
Model number: WS-C3524-PWR-XL-EN
System serial number: FAA0550L012
Configuration register is 0xF


C3524#
C3524#
C3524#sh run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname C3524
!
!
username obs password 0 cisco
!
!
!
!
!
ip subnet-zero
ip dhcp-server 192.168.102.34
!
!
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
switchport access vlan 10
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
no ip directed-broadcast
no ip route-cache
shutdown
!
interface VLAN10
ip address 192.168.102.35 255.255.255.224
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 192.168.102.33
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
exec-timeout 5 0
password cisco
login local
transport input telnet
!
end

C3524#
C3524#
C3524#
===============


OBS1200MSC#
OBS1200MSC#
OBS1200MSC#sh ver
Cisco IOS Software, C1200 Software (C1200-K9W7-M), Version 12.3(8)JEE, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Thu 09-Dec-10 08:59 by alnguyen

ROM: Bootstrap program is C1200 boot loader
BOOTLDR: C1200 Boot Loader (C1200-BOOT-M) Version 12.2(8)JA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

OBS1200MSC uptime is 0 minutes
System returned to ROM by power-on
System image file is "flash:/c1200-k9w7-mx.123-8.JEE/c1200-k9w7-mx.123-8.JEE"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
.

cisco AIR-AP1210          (PowerPC405GP) processor (revision B0) with 15138K/1236K bytes of memory.
Processor board ID FOC082228ME
PowerPC405GP CPU at 196Mhz, revision number 0x0145
Last reset from power-on
1 FastEthernet interface
1 802.11 Radio(s)

32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:11:21:DA:0C:90
Part Number          : 73-8704-07
PCA Assembly Number          : 800-23211-08
PCA Revision Number          : A0
PCB Serial Number          : FOC082228ME
Top Assembly Part Number          : 800-23304-07
Top Assembly Serial Number          : FHK0829J09A
Top Revision Number          : B0
Product/Model Number          : AIR-AP1210          

Configuration register is 0xF

OBS1200MSC#
OBS1200MSC#
OBS1200MSC#
OBS1200MSC#
OBS1200MSC#
OBS1200MSC#sh run
Building configuration...

Current configuration : 1992 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname OBS1200MSC
!
enable secret 5 $1$5giA$r0nw191njGymjS0E8px/E.
!
ip subnet-zero
no ip domain lookup
ip dhcp excluded-address 192.168.102.33 192.168.102.35
!
ip dhcp pool demo
  network 192.168.102.32 255.255.255.224
  default-router 192.168.102.33
  dns-server 213.56.106.226
!
!
no aaa new-model
dot11 syslog
!
dot11 ssid 1200MSC
  vlan 10
  authentication open
  guest-mode
!
!
!
username Cisco password 7 14341B180F0B
!
bridge irb
!
!
interface Dot11Radio1
no ip address
no ip route-cache
!
ssid 1200MSC
!
speed basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
no power client local
power client 5
power local 5
station-role root
antenna receive right
antenna transmit right
world-mode dot11d country-code HK both
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1.10
encapsulation dot1Q 10
no ip route-cache
bridge-group 10
bridge-group 10 subscriber-loop-control
bridge-group 10 block-unknown-source
no bridge-group 10 source-learning
no bridge-group 10 unicast-flooding
bridge-group 10 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface FastEthernet0.10
encapsulation dot1Q 10
no ip route-cache
bridge-group 10
no bridge-group 10 source-learning
bridge-group 10 spanning-disabled
!
interface BVI1
ip address 192.168.102.34 255.255.255.224
no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
!
end

OBS1200MSC#
OBS1200MSC#
OBS1200MSC#


============

Answer
Hi Joseph,

It might be a licensing issue.  I can't really tell from that config if everything is in place or not.  Make sure you are running the latest version - that's the first thing Cisco would make you do if you called them.  May I assume that you have support on this product?

Here are some resources to help.  These guys should totally know EXACTLY how to best help you

CISCO "ALL EXPERTS" - WIRELESS - MOBILITY
https://supportforums.cisco.com/community/netpro/expert-corner/ask-the-experts/wireless-mobility

CISCO SUPPORT COMMUNITY - WIRELESS
https://supportforums.cisco.com/community/netpro/wireless-mobility

MORE RESOURCES
--------------------------------------
CISCO 1200 TROUBLESHOOTING GUIDE
http://www.cisco.com/en/US/docs/wireless/access_point/1200/installation/guide/12

CONFIGURING DHCP FOR LIGHTWEIGHT ACCESS POINTS - 1200 SERIES
http://www.cisco.com/en/US/docs/wireless/access_point/1200/installation/guide/12

Default SSID and Radio Behavior
http://www.cisco.com/en/US/docs/wireless/access_point/1200/installation/guide/12

SUPPORT
http://www.cisco.com/cisco/web/psa/default.html?mode=prod&level0=278875243

I'm not as good w/ Cisco IOS as I used to be, and a lot has changed since I did this stuff manually.  I primarily use GUIs these days and generally don't have direct access to Cisco gear since it's customer-owned.  So I'd rather put you in touch w/ the real guru's so that you can get things going asap.

Regards,

J.

General Networking/Lan/Wan

All Answers


Answers by Expert:


Ask Experts

Volunteer


Jeff K

Expertise

I'm a Network and Application Performance Specialist, and have worked for some of the best software companies in the world.

Experience

I have over 20 years in Information Technology & Networking.

Education/Credentials
Lots of hard work, study and real-world experience. I've had some formal training along the way but most of my knowledge is from working in the field, not the classroom.

©2016 About.com. All rights reserved.