You are here:

Macintosh OS/browser for Tumblr use - ?


Hello Jeff -

I have an iMac 21.5" unit, 2 or 3 years old, using Mac OS X 10.6.8 with 4 Gigs of memory.  The only add-ons are a printer and an Ooma.  I use TW Roadrunner, medium speed.

Whenever I visit Tumblr, there is a a glaring headline:  YOUR SAFARI BROWSER IS ABOUT TO BE USELESS!  DOWNLOAD CHROME OR FIREFOX - ASAP!   I'm a computer novice and I don't know what to make of this.  Why is my Safari 'no good' - ?  Should I add another browser?  Please advise.

Thank you -  Mark

Hi Mark.

Older versions of Safari are being phased out by Tumblr. They're suggesting Chrome or Firefox as alternatives.

I have both on my system (I use all three at times) - and while you'll miss some integration with iOS (iphone or iPad), you'll see there's quite a bit of tumblr specific extendability (via extensions or add ons) that make Chrome or Firefox excellent choices.

Yes, I'd download and try both.

Macintosh OS

All Answers

Answers by Expert:

Ask Experts


Jeff Greenberg


I can comfortably answer most basic/advanced questions regarding Macintosh hardware and software - nowadays only OSX. In fact, if it's prior to 10.3, there's a good chance I'll reject your question. Forget OS9 stuff - Igave up OS 9 ten years ago). Please do not ask me about OS9. My particular specialties are in Video editing/DVD authoring. I am a certified trainer in the "pro apps" (Final Cut, DVDSP, Soundtrack, Motion). I have been using Macs since 1985.


I'm an Apple Cert. Trainer for FCP, DVD SP, since the inception of this program. I've was
certified as an Apple Cert. Technician back in 1989.

Videography, Macworld, Tibits

BA film- Penn State. Certifications from Apple, Adobe and Avid for training.

©2016 All rights reserved.