You are here:

Major Appliances/freezer thermostat

Advertisement


Question
Hi, my 2009 Ewave [yeah I know but it was the only one that fit the space in garage] 5cu ft. freezer stopped running. I am trying to see if it might just be the thermostat. I do not hear a click when advancing the dial. I put my multimeter across the thermostat terminals when the dial was advanced and received no reading. However at spaced intervals I can hear a hum and click down by compressor. Even when that happens I still get no reading at the terminals. Does this sound like a bad thermostat? If so I can only find thermostat part with # MBF24 while mine is MBF33. They look exactly alike. Am I right in assuming that the 24 and 33 refer to the length of the sensor wire? If it is not the thermostat I will junk the unit. Thank you, Jack  Barnes

Answer
that is telling me the starter on the compressor is probably your culprit... the thermostat is sending power to it...but it is not starting?  the clicking is usually the give away... now the tough part will be finding a replacement....I know nothing about EWave...because they usually do not have any parts available...I can try and match it if you take a picture  

Major Appliances

All Answers


Answers by Expert:


Ask Experts

Volunteer


Eric Campion

Expertise

We have been repairing appliances for over 36 years and have owned our own business for the same. We can help in any or almost all complaints or at least give you some intelligent input to help you make rational decisions. You can visit our website at http://www.affordableappliance.com

Experience

36 years owning our business and repairing Major Home Appliances.

Organizations
Chamber of Commerce. Better Business Bureau. Pottsville Business Association. EXPERIENCE

Education/Credentials
36 Years of Working on Major Home Appliances and selling parts. Our office staff is top notched in the Major Home Appliance Service and Part Sales Business

©2016 About.com. All rights reserved.