Microsoft Internet Explorer/https connection problem


Hello, A website that I've visited many times in the past has suddenly stopped allowing me access. In IE9, after typing the website in the address bar I get "Diagnose Connection Problems", I click on that and I get a message that the site is not set up to establish a connection on port "https" with this computer.

This company I work for provides this site to employees and I'm able to access it through the computer at work.

I've tried Mozilla Firefox and Google Chrome and I get that the site is unavailable.

I've shutdown and rebooted my computer many times and deleted temporary files, history and cookies but doing this hasn't helped.

I'm using Windows Vista Home Premium.

Thanks for any help you can provide.


Hi John,

Regarding your issue, there are many reasons as why your browser is unable to access secure website. I would suggest to follow the steps in the link that are also applicable for IE 9 windows visa machine.

Let me know if that fixes your issue and in case of further issues, please let me know.


Sandeep Handoo

Microsoft Internet Explorer

All Answers

Answers by Expert:

Ask Experts


Sandeep Handoo


I can also answer questions related to Win 98, Win ME, Windows Xp,windows 2000,Windows Vista, Windows 7,Windows 2003 Server,Windows Server 2008, Redhat Linux,Internet connectivity, Virus, Malware, Spyware and home networking.


More than 13 Years of experience.

Graduate in Electronics **_** Post Graduate in computer Science **_** Microsoft Certified Professional **_** Microsoft Certified Systems Administrator on Windows 2003 server Security**_** Microsoft Certified Systems Engineer on Windows 2003 Server Security**_** Microsoft Certified Technology Specialist** MCTS Server 2008 Active Directory, Configuration/Windows Server 2008 Applications Infrastructure, Configuration/Windows Server 2008 Network Infrastructure, Configuration**_**ITIL V3 Foundation Certified.

©2016 All rights reserved.