You are here:

Microsoft Outlook/outlook 2010 problem


Hi Nancy

I am using Outlook 2010. My OS is Win7 Ultimate.
When I open a message in Outlook 2010 and attempt to connect to a link in the message I get the following error message:

General failure. The URL was:

"http//.............". Application not found.

This has only happened in the last couple of days. Prior to that all was working well. Even if I go back to older messages which were OK in the past I get the same result.

Can you help please?


John, I have not seen this issue before but in checking I would ask if you have recently installed or updated a browser other than the Internet explorer?  

I would check that the IE is the default browser by going to the Tools menu on the Internet Explorer > Internet options > Programs and check that the Internet Explorer is the default.

If this does not work, I would do a browser search on the error you received.

Following is a link from Microsoft help community that might be helpful. outlook 2010 General failure. The URL was: "http//.............". Application not found.

If you see directions to edit the computer registry, be very sure that you understand and that an error in the registry could result in a malfunction of your computer.

All the best.


Microsoft Outlook

All Answers

Answers by Expert:

Ask Experts


Nancy Janyszeski


Creating,sending, receiving e-mail, scheduling calendar items, tasks, using the journal, recurring appointments, default settings, Office 2003, Vista, 2007, 2010, 2013.


Vocational School Instructor in the Microsoft Office Suite . I am Microsoft Office User Specialist (MOUS) Master Certified and was certified as a MOUS Authorized Instructor. ICDL certified, Microsoft Office 2010. Instructional design and test writer for Skills Advantage,

Microsoft Master Certified and ICDL certified Microsoft Office 2010

©2016 All rights reserved.