You are here:

Video Game Repair/CRUISIN WORLD VIDEO GAME

Advertisement


Question
GAME STARTS TO POWER UP, LED S LIGHT UP BUT THE TEST SEQUENCE DOES NOT START.

NO VIDEO AND NO GAME SOUNDS. EVERYTHING DEAD. I HAVE CORRECT VOLTAGES AT THE EDGE CONNECTOR. 5,-5,12 VOLTS

Answer
Gday Rick,

Manual...
http://www.arcade-museum.com/manuals-videogames/C/Cruisn%20World%20Single%20SitD

I would firstly check the 2 fuses mounted on the PCB board near the heat syncs.  Make sure they are okay and not blown. (They are 3A fuses)

Secondly check your dip switches on U97, bank 2.  Make sure 6 is off (Linking) and 7 & 8 are on (Making this board the master).  Alternatively to get it to go automatically to go to test mode turn Off Dip switch 1 on bank 2)

Is there anyway of testing the monitor?  As when the board boots you should get a rug test at least.  If you not getting that maybe your monitor is not working, although your board could be screwed up causing the problem.  (If you have 2 units your could always just start swapping parts to test what is working where)

Hope this helps.

Octane

Video Game Repair

All Answers


Answers by Expert:


Ask Experts

Volunteer


Octane

Expertise

I can answer questions on Arcade or Home Console repair or modification.

Experience

Repair, rewire, modification, rebuild, restore. (I repair numerous business and private arcade/pinball machines in my area of the state. I partner with a shop that stocks older console based systems and games, I am the one that repairs them back to working order.)

Education/Credentials
Have been building, customizing and repairing all types of arcade games since 2004. I have been repairing and modifying video games since the late 80's. (Most of my knowledge is self learnt and following others that have trailblazed in the industry.)

©2016 About.com. All rights reserved.