You are here:

Video Game Repair/1979 Space Invaders

Advertisement


Question
I have a 1979 Space Invaders arcade game which had been working fine until I had to move it to another room. Now when it is powered on all you get on the monitor is a screen with an orange bar at the top then a white field then a green field. The game sounds still seem to be working and the game seems to be playing in the background, just no picture. not as much fun without the game screen. Thank you

Answer
When you moved the game, it's likely that the monitor came unplugged or the fuse providing the power blew. With the game unplugged, check the fuses at the bottom of the cabinet, and unplug and re-plug the board harness. If you have an eraser, use it to gently clean the contacts on the main board where the harness plugs in.

Hope this helps,
Brian

Video Game Repair

All Answers


Answers by Expert:


Ask Experts

Volunteer


Brian Penzone

Expertise

I can answer questions regarding coin-operated arcade game questions down to the logic board. Error codes, erratic operation, dead boards, I can help with them all. I can help with video monitors on a very limited and basic level only.

Experience

I have spent nearly 20 years as an avid arcade collector, and spent nearly 10 of those years as the lead tech for a large arcade operator, doing work for manufacturers and other coin-operated amusement companies around the globe. I maintain a good sized collection of arcade games, as well as a large inventory of spare parts for a wide range of arcade machines.

Education/Credentials
BA from The Ohio State University, Associates from DeVry University

©2016 About.com. All rights reserved.